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1. Introduction

1.1 Introduction

Dear customer, thank you for choosing imec's hyperspectral imaging solutions.

HSI Mosaic is an advanced hyperspectral imaging software for cameras with an imec snapshot
spectral imaging sensor. The main purpose of the software is acquiring and processing data
into high quality hypercube data sets. The snapshot sensor at the camera's core is equipped
with an integrated array of narrow band lters, patterned in a mosaic layout. This enables
video rate acquisition of spectral image data with the ease of use of a regular machine vision
camera.

Figure 1: Snapshot sensor

The software enables acquisition, processing and analysis of hyperspectral image data. It offers
you the exibility to congure a range of acquisition parameters to tailor the data acquisition
and helps you to acquire good quality irradiance, reectance and transmittance data. It also
provides several useful visualization tools and a built-in classier to quickly visualize and analyze
the acquired data.
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1.2 The HSI Mosaic workow

Figure 2: The HSI Mosaic workow

HSI Mosaic was designed to get the maximum performance out of the imec hyperspectral
sensor. For this reason, the software rst acquires raw data with minimum overhead after
which the user can process them to maximum quality hyperspectral data cubes.

These raw data can also be exported to disk and imported at a later stage to reprocess with
different processing settings.

1.3 The manual's objectives

The HSI Mosaic user documentation aims to:

• Familiarize you with the user interface and utilities, addressed in the rst chapter
General HSI Mosaic functionalities and utilities on page 9.

• Provide you with correct workows and accompanying instructions to efficiently
acquire and analyze images. This goal is tackled in three phases, each covered in a
chapter:

• Connecting the camera on page 16
• Acquiring images on page 20
• Data processing, viewing and exporting on page 31
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2. General HSI Mosaic functionalities and utilities

2.1 The HSI Mosaic user interface

Status colors in the HSI Mosaic user interface

Text and graphic elements such as lines, frames and icons can change color depending on their
status.

A look at icons in the Selection panel in the Analyze tab explains in a simple way how colors
are used to indicate the status of a user interface element.

Figure 3: Color use in the user interface

Color Example Description

Permanent blue Selected

Blue at mouseover Selectable

Greyed out Non-selectable
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User interface elements

Figure 4: User interface elements

№ UI Element Description

1 Title bar Software title

Minimize, maximize and close window

2 Tabs Navigate to the different tabs. The Analyze tab is selected.

3 Panel Expandable/collapsible grouped software functionality, for
example, the Processing panel

4 Toggle button Enable/disable button (or just showing the enabled/disabled state
of the according functionality)

5 Drop-down list To select an option from a list

6 Radio button To select functionality options

7 Handle bar To change width of a user interface element

8 Text eld To enter a text or a value

9 Slider To adjust parameter settings

10 Image window Displays the current camera view or acquired image

11 Icon General user interface element function

12 Utility menu Access to utilities as language, view, logs, help.

13 Spectrograph
panel

Shows the spectra of the selections on the image

14 Histograph panel Shows the histograph of the selections on the image
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Table 1: User interface elements (Analyze tab)

See also
The utility menu on page 13
General user interface functionality on page 11

2.2 General user interface functionality

2.2.1 Change the width of the image window and the panels

In the Analyze tab, the width of the image window and accordingly the left or right panels can
be changed.

Figure 5: Vertical handle bar

1. Grab the vertical handle bar or a vertical edge of the image window.
2. Steer left or right.
3. Release the handle bar or the edge of the image window.

2.2.2 Expand/collapse a panel

Figure 6: Expand and collapse arrows

Click the panel title, for example in the Connect tab, click Available systems. You can also
click the arrows to expand or to collapse the panel.

See also
Zoom in/out on an image on page 12

2.2.3 Flip or rotate an image
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Click one of the following icons:

•  Flip vertically
•  Flip horizontally
•  Rotate clockwise
•  Rotate anticlockwise

See also
Zoom in/out on an image on page 12

2.2.4 Zoom in/out on an image

You can zoom in or out on an image in for example the image window or the class image
panel.

1. Move the mouse pointer to the image window or panel.
2. Scroll up/down.

See also
Flip or rotate an image on page 11
Expand/collapse a panel on page 11

2.2.5 Show/hide an item or selection

An item can be set to visible or hidden.

Click or double click one of the following icons to change its status:

Icon Status

• Blue: Visible item
• White: Hidden

• Blue: Visible selection
• White: Hidden selection

2.2.6 Export/import: overview

Exports are performed with the  icon.

Imports are performed with the  icon.

Detailed export/import dialog box instructions can be found in each specic topic (see topic
references in the table below).

Tab Panel Topic reference

Analyze

Acquire

Rendering Export the current rendered image on page 23
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Tab Panel Topic reference

Acquire Context Export/import a context on page 29

Analyze IO Export collections and/or context on page 33

Import an unprocessed collection to analyze on page
34

Analyze Selection Export the selection information and/or mask for reuse
on page 45

Import the selection information and/or mask for reuse
on page 45

Analyze Classication Export the classier on page 51

Export the classier on page 51

Analyze Spectrograph Export spectrograph data on page 46

Analyze Class image Export the class image on page 52

Analyze Metadata Export metadata on page 53

Table 2: Export/import instruction references

2.3 The utility menu

The utility menu  allows you to view software info, set preferences, get help, ...

Option Description

 Languages Select one of the available languages, close
and restart the software.

View Select a view:

• Default: high-quality workow with
optimal default settings; complex
settings are hidden in the user
interface.

• Extended: all processing and settings
information and functionality for in
depth comprehension. This allows
you to have a better control over
the hyperspectral imaging process.
See Extended view information in the
Analyze tab on page 38.
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Option Description

Logs > Verbosity The verbosity level of a log message reects
the amount of information the log message
provides. The available levels; in ascending
order of the amount of info, are:

• Error
• Warning (default)
• Info
• Verbose
• Debug

NOTE
The higher the amount of info is logged,
the more disk space will be consumed.
It is therefore recommended to only use
the levels Info, Verbose and Debug as
long as required and then switch back to
Error or Warning.

NOTE
Logs are stored in ...\AppData
\Roaming\imec\HSI Mosaic
\logs of your user folder, for
example; C:\Users\<userName>
\AppData\Roaming\imec\HSI
Mosaic\logs

.

 Help > Contact us For support, questions and remarks, ll in and
send the Contact us form that appears.

You can also send an email to
hsisupport@imec.be.

 Help >  > About. Version information is shown and you can
click Visit us to open the Hyperspectral
imaging website (https://www.imec-int.com/
en/hyperspectral-imaging).

Table 3: Utility menu options

See also
The HSI Mosaic user interface on page 9
General user interface functionality on page 11
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2.4 Extended view functionality

Extended view functionality

Select the bit depth of the camera on page 22

Enable/disable spatial median ltering on page 35

Enable/disable the angularity correction on page 36

Extended view information in the Analyze tab on page 38:

• Bias correction:
• Demosaicing:
• Alignment:

Table 4: Extended view functionality

2.5 System requirements

Requirement Minimum Recommended

OS Windows 10

64 bit

Windows 10

64 bit

Processor Intel i5 7th gen or AMD Zen

2 GHz

64 bit support

Intel i7th gen or AMD Zen +
or better

4 GHz or faster

64 bit support

RAM 8 GB 32 GB or more

Disk SSD SATA III

500MB/s write speed

> 5 GB free storage

Table 5: System requirements
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3. Connecting the camera

3.1 Authenticate a camera in HSI Mosaic

When you connect a camera for the rst time, it is not yet recognized in the HSI Mosaic
software. A system/camera card will be shown for the new camera, indicating the sensor data
is not found.

Figure 7: System/camera card of a non-authenticated camera

To authenticate the camera, you will have to add the calibration le to HSI Mosaic. The
calibration le name contains the serial number of the sensor; for example the le name
CMV2K-SSM4x4-595_860-13.10.5.4 with 13.10.5.4 being the sensor serial number.

1. Connect the camera to the computer and turn the camera on.
2. Open the Connect tab.
3. At the Available systems panel, click .

The system/camera cards of cameras that are turned on and connected to your computer
are shown.
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4. In the system/camera card of the camera that you want to authenticate, click , browse to
the calibration le and click Open or drag and drop your le to the card.
The camera is now recognized and the sensor data in the system/camera card are lled in.

Figure 8: System/camera card of an authenticated camera

See also
Connect a camera to HSI Mosaic on page 17
Find cameras connected to your computer on page 18
Connecting the camera on page 16

3.2 Connect a camera to HSI Mosaic

To connect a camera to HSI Mosaic it has to be authenticated.

1. Connect the camera to the computer and turn the camera on.
2. Open the Connect tab.
3. At the Available systems panel, click .

The system/camera cards of cameras that are turned on and connected to your computer
are shown.

4. In the system/camera card of the camera that you want to connect, click Connect. When
a dialog box appears, conrm if you want to use your last optical setup.
The camera connects to HSI Mosaic and the Acquire tab opens.

See also
Authenticate a camera in HSI Mosaic on page 16
Find cameras connected to your computer on page 18
Determine context and non-uniformity (irradiance pipeline) on page 25
Connecting the camera on page 16
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3.3 Find cameras connected to your computer

When opening HSI Mosaic, it checks for cameras that are connected to your computer to
show them in the Available systems panel. However, if the system/camera card of your
camera isn't shown because, for example, you connected a camera to your computer after
opening HSI Mosaic, you have to refresh the Available systems panel.

NOTE
HSI Mosaic will only nd cameras that are switched on.

1. Make sure your camera is connected to the computer and the camera is turned on.
2. Open the Connect tab.
3. At the Available systems panel, click .

See also
Connect a camera to HSI Mosaic on page 17
Authenticate a camera in HSI Mosaic on page 16
Connecting the camera on page 16

3.4 Show the spectral response of a system

The system's spectral response reects the sensitivity of the system per spectral band to light
at different wavelengths. The system response is a combination of the following factors:

• The sensor quantum efficiency at each wavelength (i.e., how efficiently photons are
converted to electrons).

• The transmission efficiency of the narrow-band Fabry-Pérot lters on the sensor.
• The attenuation through other components in the system, such as the system level

band pass lter.

Multiple system variants may be possible depending on the sensor type and other system level
lters added in the optical path to select a specic spectral range. When available, you can
select them in the Correction matrix drop-down list (step 3 of this procedure).

NOTE

This selection is purely visual and does not impact the software. It is important to select the
appropriate matrix in the pipeline in the Analyze phase.
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Figure 9: The spectral response

1. Open the Connect tab.
2. At the Available systems panel, in the system card, click View.

In the Details panel the quantum efficiency-wavelength graph, representing the spectral
response, is shown for the system.

3. Select the Correction matrix: from the drop-down list.

See also
Show or hide the camera information
Show or hide the sensor information
Connecting the camera on page 16
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4. Acquiring images

4.1 Acquire workow

Acquiring images of the highest possible quality is by far the most crucial step in your
workow. HSI Mosaic's irradiance pipeline (reference spectrum pipeline) is a method to
acquire top quality images in all conditions and in any environment.

In addition to the irradiance pipeline, HSI Mosaic still offers the classic but much less widely
applicable reectance pipeline (full coverage pipeline).

1. The rst step to achieve a quality image is the accurate conguration of the camera:

1. We recommend to turn Demosaicing: on (default), see Enable/disable demosaicing on
page 22. This allows you to optimally set the integration time and to focus the lens
properly in the next steps. You can select Tiles (all bands are shown side by side in the
image window) or Single band (only one selected band is shown in the image window)
and optimize these settings in each band, see Adjust the Acquire tab rendering settings
on page 23.

2. Roughly adjust the Integration time (ms): of the camera, see Set the integration time
of the camera on page 21 and then focus the lens on the sample.

3. Fine tune the Integration time (ms):, see Set the integration time of the camera on
page 21.

2. In the second step, you determine the context parameters depending on the pipeline you
will use and acquire the image.

• The irradiance pipeline on page 24

• Determine context and non-uniformity (irradiance pipeline) on page 25
• Dene and add a custom lens (irradiance pipeline) on page 26
• Add a predened lens (irradiance pipeline) on page 26
• Delete a lens (irradiance pipeline) on page 27

• The reectance pipeline on page 27

When you acquired an image, you can export the context parameters and reuse them for
new acquisitions with the same context, see:

• Export collections and/or context on page 33
• Export/import a context on page 29

NOTE
The larger the aperture (diaphragm opening), the lower the f-number of the lens and the
more light is collected, but the shallower the depth of focus. The maximum aperture (lowest
f-number) to be used is f/2.8. We recommend to start focusing at f/2.8. If you examine a 3D
sample, start focusing at the average depth of the sample. Then gradually increase the focus
depth (by increasing the f-number) until the part of the sample that matters for your research
is in focus.
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4.2 The acquire tab histogram

The Histogram in the Acquire tab shows the Pixel counts as a function of the Digital
number.

To optimally use the dynamic range of the sensor, you can adjust the integration time and
monitor the histogram: a higher dynamic range results in a higher pixel count in the histogram.
See Set the integration time of the camera on page 21.

You can highlight the pixels in the image window with a pixel count below a set Lower
threshold or above a set Upper threshold of the Digital number. Standard the Lower
threshold is 0 and the Upper threshold  is at the maximum. With the standard settings,
only saturated pixels are highlighted (red).

You can:

• Make the thresholds Visible ( ) or Hidden ( ).
• Change the color of the thresholds.
• Change the thresholds by entering their values, with the arrows or with the sliders.
• Reset ( ) the threshold values to their standard values.

4.3 The temperature graph

The Temperature graph in the Acquire tab shows the sensor Temperature (°C) as a
function of the Acquisition time (hh:mm) of the last 30 minutes.

Sensor temperature affects the leakage current of the pixels. Calculations that use dark
reference images will compensate for sensor leakage.

HSI Mosaic can acquire and save multiple dark reference images during an image acquisition
session to cope with the temperature changes. To get the best spectral accuracy in
acquisitions, wait until the camera temperature stabilizes before acquiring images and white/
dark references. Also, wait for temperature stabilization between individual acquisitions during
longer sessions.

NOTE
Usually, the temperature decreases when the lens is covered or when a snapshot is taken.

CAUTION
In direct sunlight or near a heat source, the temperature of the sensor can become too high.
Move the camera or use insulation to shield it.

4.4 Set the integration time of the camera

The rst step to achieve a quality image is the accurate conguration of the camera, with
setting the integration time and focusing the lens, see Acquire workow on page 20.

The integration time determines how long the sensor of the camera collects photons from the
scene. The longer the integration time, the more light is collected from the scene before the
sensor is read and the higher the pixel intensity values.
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The goal is to expose the sensor to the light of the scene for as long as possible so that the
intensity (digitized and recorded as a digital number) of the pixels is as high as possible without
saturation of the sensor. In this way, the dynamic range of the sensor is optimally used.

NOTE
You can monitor the histogram to optimally use the dynamic range of the sensor, see The
acquire tab histogram on page 20.

Standard, HSI Mosaic shows the saturated pixels in the rendered image as red pixels. Start
with a long integration time, then reduce it until there are no red pixels visible in areas of
interest for the scene.

NOTE

Saturation (red pixels) in the area of the scene background or from specular (mirror-like)
reection of the scene can be tolerated so that the intensity values of the areas of interest
can be kept as high as possible. You can for example tolerate saturation of specular reection
of a polished metal, water, a shiny glass or apple, ...

In the Acquire tab, in the Camera conguration panel, at Integration time (ms):, type
the integration time or use the slider or arrows.

See also
Select the bit depth of the camera on page 22

4.5 Select the bit depth of the camera

Bit depth is the number of bits used per pixel to digitize the intensity values into digital
numbers.

Standard (recommended), the highest bit depth is selected. You can only decrease the default
bit depth in extended view.

Decreasing the bit depth decreases precision. Since less bits are used to save the image data,
decreasing the bit depth also decreases the storage amount. Reducing the bit depth should be
avoided as much as possible, but allows higher frame rates.

In the Acquire tab, in the Camera conguration panel, at Bit depth:, select the desired
bit depth from the drop-down menu.

See also
Set the integration time of the camera on page 21

4.6 Enable/disable demosaicing

An image sensor is a 2D array of light-sensitive photodiodes, the pixels. In order to capture
differences in wavelength (color), a lter array (mosaic) is placed over the sensor, so that
specic pixels register specic wavelengths of light.

Without processing (demosaicing disabled) you see the raw image. When you zoom in, you
see the 'mosaic' pattern generated by the wavelength lter array.
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A demosaicing algorithm reorders the sensor pixels into multiple band images, each
corresponding to a specic wavelength.

Demosaicing is enabled as default, rendering all band images in a grid. This rendering does not
do any other processing on the image, but allows you to optimally set the integration time and
to focus the lens properly, see Acquire workow on page 20.

1. Select the Acquire tab.
2. In the Processing panel, enable/disable Demosaicing:.

4.7 Enable/disable edge detection for focus assistance

HSI Mosaic edge detection highlights the edges of your sample. Focusing will increase the
number of highlights. You can temporary add an object with more edges than your sample (for
example, a paper with printed text) to the scene for easier focusing.

1. Select the Acquire tab.
2. In the Focusing assist panel, enable/disable Edge detection.

4.8 Adjust the Acquire tab rendering settings

Rendering settings in the Acquire tab and the Analyze tab are independent of each other.

The rst step to achieve a quality image is the accurate conguration of the camera, see
Acquire workow on page 20. While setting the integration time and focusing the lens,
with Demosaicing: turned on (default), you can select Tiles or Single band to render the
live view image in the image window and optimize these settings in each band.

1. Select the Acquire tab.
2. In the Processing panel, enable Demosaicing:.
3. In the Rendering panel, from the top drop-down list, select the rendering type:

• Tiles: all bands are shown side by side in the image window.
• Single band and select a band with the slider: the selected band is shown in the

image window.
4. At Colormap:, from the drop-down list, select an appropriate color map.

See also
Export the current rendered image on page 23
Adjust the Analyze tab rendering settings on page 38

4.9 Export the current rendered image

You can export the rendered image in the image window as PNG.

1. Select the Acquire.
2. In the Rendering panel, click  Export.

The ExportDialog dialog box appears.
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3. Browse to a Destination Folder:, enter a unique name and conrm.
The image is saved in the destination folder as a PNG le.

See also
Export/import: overview on page 12

4.10 The irradiance pipeline

HSI Mosaic's irradiance pipeline (reference spectrum pipeline) is a method to acquire top
quality images in all conditions and in any environment. This pipeline is selected by default.

The reectance pipeline is a lot more limited in use, see The reectance pipeline on page
27.

Once the camera is congured properly (integration time and focusing the lens), the context
parameters have to be determined in a lab set up, see step 1. In the following steps the actual
acquisition of your sample (in the eld or in the lab) are performed.

NOTE
When external synchronization is required, hardware triggering can be enabled.

1. Determine context and non-uniformity (irradiance pipeline) on page 25.
2. Select the Acquire tab.
3. At Lens:, from the drop-down list, select the lens mounted on your camera.
4. At F-number:, enter the used lens aperture.
5. Place your sample and a part of the white reference tile in the camera's eld of view and

adjust the focus until you see a sharp image of the sample in the image window.

To focus, you can disable demosaicing and zoom in on an edge with high contrast or use
focus assistance. see Enable/disable edge detection for focus assistance on page 23.

The part of the white reference tile in the acquired image shall be used for balancing during
analysis.

6. In the Acquisition panel, at the Name: eld, enter an acquisition name. Choose a new
name if you don't want to overwrite previous acquisitions.

7. In the Acquisition panel, perform one of the following acquisition type procedures:

• The snapshot acquisition:

1. From the Type drop-down list select Snapshot.
2. Click Acquire, (when enabled, wait for the hardware trigger), follow any pop-up

dark reference instructions and conrm if you want to analyze the acquisition.
• The video acquisition:

1. From the Type drop-down list select Video.
2. In the FPS eld, set the video recording frame rate (frames per second).

When the framerate is higher then the maximum frame rate of your setup
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(camera,computer, settings, ...), you will see that frames are dropped (in the
Dropped eld). Lower your frame rate to prevent this.

3. Click Acquire, (when enabled, wait for the hardware trigger) and follow any
pop-up dark reference instructions.

The recording starts.

You can monitor the Duration, the number of taken Images, the number of
Dropped images, the instantaneous FPS, and your computer's remaining Disk
space (GB) Disk space (GB).

4. Click Acquire and conrm if you want to analyze the acquisition.

The recording stops.

See also
The reectance pipeline on page 27
Add a predened lens (irradiance pipeline) on page 26
Dene and add a custom lens (irradiance pipeline) on page 26
Delete a lens (irradiance pipeline) on page 27

4.10.1 Determine context and non-uniformity (irradiance pipeline)

Once the camera is congured properly (integration time and focusing the lens), the context
parameters have to be determined, see Acquire workow on page 20:

• The calibration le (already imported during the connect phase, see Authenticate a
camera in HSI Mosaic on page 16)

• The optical setup, i.e. selecting the mounted lens and the aperture (f-number) used, see
Acquire workow on page 20.

• Record non-uniformity calibration images:

• The non-uniformity image
• The dark reference

The context information will be used to translate the digital numbers of the sensor back to the
irradiance.

NOTE

• This task is performed in a lab setup with the supplied white reference tile and
supplied halogen lamps with their specic spectrum. You have to repeat this step for
each lens/f-number combination.

• You can reset the context with the  button.
• When external synchronization is required, hardware triggering can be enabled.

The context information can be determined as follows:

1. Select the Acquire tab.
2. At Lens:, from the drop-down list, select the lens mounted on your camera. When your

mounted lens is not in the drop-down menu, click  to add it (as predened or custom
lens). See also Dene and add a custom lens (irradiance pipeline) on page 26 and Add a
predened lens (irradiance pipeline) on page 26 Click  to delete a lens.
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3. At F-number:, enter the used lens aperture. See Acquire workow on page 20 for
more info on setting the aperture on the lens.

NOTE
Enter 0.0 when you can't get the correct lens aperture.

4. Place the white reference tile in the eld of view of the camera. Make sure the tile covers
the whole eld of view.
The white reference tile is a critical optical component. Handle the tile with care to prevent
it from getting dirty.

5. Adjust the focus of the lens to the presumed distance of the sample you will eventually
acquire.

6. Click Non-uniformity and follow any pop-up instructions for manually covering and
uncovering the camera.
Make sure all incoming light is blocked while covering the camera, because at that moment
a dark reference will be acquired. The white reference will be acquired after uncovering the
camera.
Do not touch the lens glass to prevent it from getting dirty.

4.10.2 Dene and add a custom lens (irradiance pipeline)

1. Select the Acquire tab.
2. In the Context panel, from the Pipeline: drop-down list, select Reference spectrum.
3. At Lens:, click  New lens > Custom.

The Lens properties creator dialog box appears.
4. Enter the Manufacturer name:
5. Select the Spectral range: from the drop-down list:

• VNIR: visible and near-infrared
• SWIR: shortwave-infrared

6. Enter the Focal length (mm):.
7. Enter the Exit pupil distance (mm):. This information can be found in the data sheet of

the lens or can be obtained from the lens manufacturer.

NOTE
Enter 0.0 when you can't get the correct exit pupil distance.

8. Click OK.
The lens is created, added and selected as the current lens in the drop-down list.

See also
The irradiance pipeline on page 24
Add a predened lens (irradiance pipeline) on page 26

4.10.3 Add a predened lens (irradiance pipeline)

1. Select the Acquire tab.
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2. In the Context panel, from the Pipeline: drop-down list, select Reference spectrum.
3. At Lens:, click  New lens > Predened.

The Predened lens properties dialog box appears.
4. From the drop-down list, select a lens and conrm.

The lens is added and selected as the current lens in the drop-down list.

See also
The irradiance pipeline on page 24
Dene and add a custom lens (irradiance pipeline) on page 26

4.10.4 Delete a lens (irradiance pipeline)

1. Select the Acquire tab.
2. In the Context panel, from the Pipeline: drop-down list, select Reference spectrum.
3. At Lens:, click  Delete and conrm.

The lens is deleted and Unknown is the current lens.

See also
The irradiance pipeline on page 24

4.11 The reectance pipeline

In addition to the irradiance pipeline (default), HSI Mosaic still offers the classic but much less
widely applicable reectance pipeline (full coverage pipeline).

The reectance pipeline is a workow that is only suitable for acquiring images of a sample
smaller than the white reference used for the calibration. You want, for example, to acquire
the image of a single leaf or ower and not a whole tree or a eld of owers. This pipeline is
used in lab conditions.

The irradiance pipeline can be used in the lab and in the eld and for any sample size, see The
irradiance pipeline on page 24.

NOTE
When external synchronization is required, hardware triggering can be enabled.

1. Determine context and non-uniformity (reectance pipeline) on page 28. For multiple
acquisitions with the same light, focus, and lens conditions, you don't have to repeat this
step until you reset the context with .

2. Place your sample in the camera's eld of view and adjust the focus until you see a sharp
image of the sample in the image window.
To focus, you can disable demosaicing and zoom in on an edge with high contrast or use
focus assistance. see Enable/disable edge detection for focus assistance on page 23.

3. In the Acquisition panel, at the Name: eld, enter an acquisition name. Choose a new
name if you don't want to overwrite previous acquisitions.
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4. In the Acquisition panel, perform one of the following acquisition type procedures:

• The snapshot acquisition:

1. From the Type drop-down list select Snapshot.
2. Click Acquire, (when enabled, wait for the hardware trigger), follow any pop-up

dark reference instructions and conrm if you want to analyze the acquisition.
• The video acquisition:

1. From the Type drop-down list select Video.
2. In the FPS eld, set the video recording frame rate (frames per second).

When the framerate is higher then the maximum frame rate of your setup
(camera,computer, settings, ...), you will see that frames are dropped (in the
Dropped eld). Lower your frame rate to prevent this.

3. Click Acquire, (when enabled, wait for the hardware trigger) and follow any
pop-up dark reference instructions.

The recording starts.

You can monitor the Duration, the number of taken Images, the number of
Dropped images, the instantaneous FPS, and your computer's remaining Disk
space (GB) Disk space (GB).

4. Click Acquire and conrm if you want to analyze the acquisition.

The recording stops.

NOTE
A new dark reference acquisition is only needed when it is not yet available for the current
temperature and integration time.

See also
The irradiance pipeline on page 24

4.11.1 Determine context and non-uniformity (reectance pipeline)

The reectance pipeline requires a full eld of view white reference tile measurement that
includes information about:

• The non-uniformity of the sensitivity of the system due to lens vignetting, variance of
silicon thickness of the sensor, etc

• The non-uniformity of the illumination of the scene
• The light spectrum

1. Select the Acquire tab.
2. Place a white reference tile (for example, 95% reectance) in the eld of view of the

camera. Make sure the tile covers the whole eld of view.
The white reference tile is a critical optical component. Handle the tile with care to prevent
it from getting dirty.

3. At White reectance: enter the reectance value of your reference tile, for example,
95,00.
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4. Click White reference, (when enabled, wait for the hardware trigger) and follow
any pop-up instructions for manually covering and uncovering the camera. Make sure
all incoming light is blocked while covering the camera, because at that moment a dark
reference will be acquired. The white reference will be acquired after uncovering the
camera.
Do not touch the lens glass to prevent it from getting dirty.

5. Remove the white reference tile.

4.12 Export/import a context

The context contains les regarding calibration, the dark reference(s), the white reference, the
non-uniformity and the optical setup.

Use cases for context export/import:

• When you acquired an image, you can rst export the context of the acquisition

• In the Acquire tab (see below: step 2, Export the context )
• In the Analyze tab (see Export collections and/or context on page 33)

and then import it to reuse it for a new acquisition with the same context (see below:
step 2: Import the context).

• You can import unprocessed (raw-frame) workspace data (Import an unprocessed
collection to analyze on page 34) and its context that you previously exported, tune
the processing parameters and export the resulting processed data into hypercubes.

• When you use the irradiance pipeline for outdoor acquisitions, you can import the
context you created in a lab environment.

NOTE
Be careful not to use the same context in different circumstances. For example, using a
different f-number or a different lens always requires a new context.

1. Select the Acquire tab.
2. In the Context panel, perform one of these procedures:

• Export the context:

1. Click .

The dialog box appears.
2. At Destination, click  to select the destination Folder:.
3. At Name:, enter the folder name where all les and folders will be saved.
4. Click OK.

• Import the context

1. Click .

The Import context dialog box appears.
2. Browse for the desired context folder with the name Context and click Select

Folder.
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See also
Export/import: overview on page 12
Export collections and/or context on page 33
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5. Data processing, viewing and exporting

5.1 Hyperspectral imaging data naming conventions

Data type Description

Cube Raw or processed hyperspectral information
of a single frame

Hypercube Fully processed and exported cube

Acquisition Cube(s) that is (are) acquired in a single
process. An acquisition can have

• One cube: Acquisition Type
Snapshot

• More cubes: Acquisition Type
Video

Context Set of les that are necessary to process
a raw cube: the calibration le, the lens
information, the white reference cube,
the dark reference cube, and the sensor
temperature information

Collection Set of acquisitions that share the same
context and that are exported together. A
collection can also include context.

Table 6: Naming conventions

5.2 Analyze workow

The data processing pipelines will process the raw frame data into spectral cubes, after which
they can be viewed and exported.

The processing steps are determined by the chosen pipeline and can be partially congured to
tune the output data size and quality.

HSI Mosaic renders the processed data and enables you to analyze them through
spectrographs and histographs. You can analyze these images in real time or offline. You can
also classify images in HSI Mosaic using spectral angle mapping.
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Step Action Related topics

1 Select the data to be analyzed.

• Workspace: currently acquired
image(s).

• Live stream: real-time camera
(video-stream) data.

• Offline data: previously
exported image data.

Data input and output on page 32

Select workspace data to analyze on page
33

Select live stream data to analyze on page
34

Import an unprocessed collection to
analyze on page 34

2 Set the processing parameters. Select the processing pipeline on page
35

Enable/disable spatial median ltering on
page 35

Apply spatial resampling on page 36

Enable/disable spectral correction on
page 36

Enable/disable the angularity correction
on page 36

Apply spectral balancing (irradiance
pipeline) on page 37

Reset applied spectral balancing
(irradiance pipeline) on page 38

3 Adjust the rendering parameters. Adjust the Analyze tab rendering settings
on page 38

4 Make selections and visualize spectra. Image selection actions on page 39

Selection actions workow example on
page 40

Spectrograph analysis on page 46

Histograph analysis on page 47

5 Classify the image pixels based on the
selections.

Classication on page 48

Classication workow on page 48

Table 7: Analyze workow steps

5.3 Data input and output

In the Analyze tab, in the IO panel, you can select the image data you want to analyze and
export the processed or unprocessed (raw-frame) image data and the context.
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When your image data is a video, you can select the frame you want to see, using one of these
options:

• Move the slider
• Click the up and down arrows in the frame number eld
• Enter a frame number in the image number eld
• Click the play button to start and pause
• Click the left and right arrows

See also
Select workspace data to analyze on page 33
Select live stream data to analyze on page 34
Import an unprocessed collection to analyze on page 34
Export collections and/or context on page 33

5.3.1 Select workspace data to analyze

Workspace analysis: you can select the currently acquired image(s).

When you just nished an acquisition and you conrmed to analyze the last acquisition, HSI
Mosaic automatically jumps to the Analyze tab. In the IO panel, the last workspace acquisition
is already selected in the list with all acquired images to be analyzed.

1. In the Analyze tab, in the IO panel, at Source:, select Workspace from the drop-down
list.
The acquisition list is shown.

2. Select the name of the desired acquisition in the list.

See also
Select live stream data to analyze on page 34
Import an unprocessed collection to analyze on page 34

5.3.2 Export collections and/or context

When you acquired one or more images, you can export a processed collection of hypercubes
or an unprocessed collection of cubes, and their context. For example, you can export
unprocessed workspace data and the context and later import both to process that data into
hypercubes (spectral data cubes).

These export options are possible:

• Processed: nal export of the processed collection of hypercubes with the current
pipeline and processing parameters applied. All les are saved in the sub-folder
<name>_processed. You can then start using these hypercubes for your application,
for example, you can analyze the hypercubes in HSI Studio. See also ENVI le format
on page 53.

• Unprocessed: unprocessed or raw-frame workspace data. When you import these les
later (together with the context, see the export option below), you can still tune the
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processing parameters and generate hypercubes. All les are saved in the sub-folder
<name>_unprocessed. See also Export data XML le format on page 55.

• Context: the calibration le, the optical setup, the temperature information, the dark
reference, white reference and non-uniformity cubes. All les are saved in the subfolder
<name>_unprocessed\context .

1. Select the Analyze tab.
2. In the IO panel, from the Source: drop-down list, select Workspace.
3. Click Export.

The ExportDialog dialog box appears.
4. At Destination, click  to select the destination Folder:.
5. At Name:, enter the collection name where all les and folders will be saved.
6. At Preferences, select one or multiple acquisitions (mouse drag or press Ctrl for

multiselect).
7. At Preferences, select one or more of the following options:

• Context: the sub-folder context with nested sub-folders and the according
context les are created and saved for each selection.

• Unprocessed: the sub-folder unprocessed and a frame.raw and frame.raw.xml le
are created for each selection, Export data XML le format on page 55.

• Processed: the sub-folder processed, a RAW and an HDR le are created for each
selection, ENVI le format on page 53.

8. Click OK.

See also
Export/import: overview on page 12
Export/import a context on page 29
Import an unprocessed collection to analyze on page 34
Export metadata on page 53

5.3.3 Import an unprocessed collection to analyze

You can import unprocessed collections that you previously exported together with their
context, see Export collections and/or context on page 33, tune the processing parameters
and export the resulting processed data into hypercubes.

1. In the Analyze tab, in the IO panel, at Source:, select Offline data from the drop-
down list.

2. Click  and select the folder in Windows Explorer.

See also
Export/import: overview on page 12
Select workspace data to analyze on page 33
Select live stream data to analyze on page 34
Export collections and/or context on page 33
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5.3.4 Select live stream data to analyze

Live stream analysis: you can select real-time camera data (video-stream).

In the Analyze tab, in the IO panel, at Source:, select Live stream from the drop-down
list.
The live stream is shown in the image window. You can pause ( ) and restart ( ) the live
stream.

See also
Select workspace data to analyze on page 33
Import an unprocessed collection to analyze on page 34

5.4 Processing

In the Analyze tab, in the Processing panel you can congure how the data processing pipeline
will process the raw frame data into spectral cubes.

See also
Enable/disable spatial median ltering on page 35
Apply spatial resampling on page 36
Enable/disable spectral correction on page 36
Enable/disable the angularity correction on page 36
Apply spectral balancing (irradiance pipeline) on page 37
Reset applied spectral balancing (irradiance pipeline) on page 38

5.4.1 Select the processing pipeline

Depending on your Acquire workow on page 20, you have to select a processing pipeline.

In the Analyze tab, in the Processing panel, from the Pipeline:, select one of these
options:

• (Default) Reference spectrum (Irradiance pipeline)
• Full coverage (Reectance pipeline)

5.4.2 Enable/disable spatial median ltering

By default spatial median ltering is enabled on each of the hypercube's band images. As such,
the lter is active only in the spatial domain of the data. You can only enable/disable spatial
median ltering in extended view.

Signal spikes (hot and dead pixels and other outliers) cause salt and pepper noise (bright and
dark spots) in the image. You can use the spatial median lter to smoothen the image by
removing the signal spikes. The spatial median lter replaces each pixel intensity value by the
median value of its neighborhood pixels.

The lter size denes the number of surrounding pixels used by the lter to calculate the
median. With a 3x3 lter size, 9 pixels are used to calculate the median. A 5x5 lter uses 25
pixels, which results in a stronger ltering of the image data.
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NOTE
A large lter size requires a lot of processing power for big data sets.

1. In the Analyze tab, in the Processing panel, enable/disable Spatial median ltering:.
2. (Optional) Select a different Filter size: from the drop-down list.

See also
Apply spatial resampling on page 36

5.4.3 Apply spatial resampling

The processing pipeline incorporates a kind of de-bayering algorithm to demosaic the raw
image into individual band images. In this demosaicing step, each band image is resampled to a
new grid. This spatial resampling can be congured to determine the pipeline's output data size
up to the native sensor size.

1. In the Analyze tab, in the Processing panel, enable Spatial resampling:.
2. Select one of the following options:

• Full sensor to resample data for the whole sensor resolution.
• Custom and set you own resolution for resampling by adjusting the Width: or

Height:.

See also
Enable/disable spatial median ltering on page 35

5.4.4 Enable/disable spectral correction

Spectral correction is applied by default. Spectral correction or deconvolution removes
all transformations introduced by the system to translate the captured spectral signal into
discrete digital numbers. As such, spectral correction is a model inversion step and recomputes
the true light spectrum captured by the lens of the camera.

1. In the Analyze tab, in the Processing panel, disable/enable Spectral correction:.
2. (Optional) Select another Correction matrix: (availability depends on your system) from

the drop-down list.

5.4.5 Enable/disable the angularity correction

Angularity correction is enabled by default. You can only disable the angularity correction in
extended view.

Light reected or transmitted by a sample will be projected by the lens onto the sensor at
specic angles. Depending on the place on the sensor, these angles will be different. The lters
on the sensor are Fabry-Perot interference lters and are for that reason sensitive to the angle
of the incident light in a cosine relation. The angularity correction will compensate for the
spectral shift caused by these differences.

Since the focal length, exit pupil distance and aperture (f-number) of the lens determine these
angles, proper lens selection and aperture adjustment during the Acquire phase are crucial to
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ensure a correct angularity correction, see Determine context and non-uniformity (irradiance
pipeline) on page 25.

In the Analyze tab, in the Processing panel, enable/disable Angularity:.

5.4.6 Select the spectral resampling method

Spectral resampling is applied by default.

After the angularity correction is applied to the data, each pixel in a band image will have
the value which corresponds to a measurement at a slightly different wavelength than the
other pixels. This wavelength depends on the location of the pixel on the sensor. To have
consistent information inside a band image, each pixel in that band image must be resampled
to a common wavelength. The wavelengths corresponding to the virtual bands created like this
can be selected in two different ways:

• Non-equidistant (default): such that they are as close as possible to the actual bands of 
the lters, but taking into account the average wavelength shift.

• Equidistant: such that the spectral range of the sensor is uniformly sampled. Depending 
on the sensor model, equidistant resampling can cause a small or a
signicant loss in spectral accuracy. If the virtual bands thus created are too far from the 
original bands of the sensor, equidistant resampling can produce very inaccurate results. 
Equidistant resampling can however be a prerequisite for a number of post-processing 
algorithms.

In the Analyze tab, in the Processing panel, select a Method from the drop-down list:

• Non-equidistant
• Equidistant

5.4.7 Apply spectral balancing (irradiance pipeline)

Spectral reectance or transmittance is retrieved by dividing the spectral irradiance by the light
source spectrum. This process is also called white balancing, and can be done by estimating the
light spectrum from a spectrally at surface (to obtain reectance) or a perfectly transmissive
surface (to obtain transmittance).

It is recommended to position a reference target with a spectrally at response somewhere in
the eld of view and to select a region in that target for spectral balancing.

NOTE

You can click  to use the non-uniformity image in the context as a reference, but only when
a white reference is not available because it will cause less spectral accuracy. Click the 
again to reset.

1. In the Analyze tab, in the Selection panel, select one of the following selection tools:

• Freehand
• Line
• Rectangle
• Circle
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2. In the Processing panel, at Spectral balancing, enter the Coefficient: of your white
reference, for example 0.95 for a 95% white reference.

3. In the Processing panel, at Spectral balancing, click .
4. In the image window, click and hold to drag a selection in the white reference.

The balancing is applied instantly.

See also
Reset applied spectral balancing (irradiance pipeline) on page 38

5.4.8 Reset applied spectral balancing (irradiance pipeline)

Resetting previously applied white balancing can be handy when the selected area while
balancing wasn't signicant large enough or when you accidentally balanced more than once.

In the Analyze tab, in the Processing panel, next to Spectral balancing, click the toggle
button.

5.4.9 Extended view information in the Analyze tab

In the Analyze tab, the extended view provides you with all processing and settings
information and functionality for in depth comprehension; this allows you, for example, to
export unprocessed data (see Export collections and/or context on page 33) which you
can use for your own processing or experimental work (for example, in Python or Matlab).

NOTE
Unprocessed data is not true spectral data and must be treated with care.

Analyze tab Extended View Description

Bias correction: Indicates the processed image was corrected
using the dark reference, see The reectance
pipeline on page 27 or The irradiance pipeline
on page 24.

Demosaicing: Indicates demosaicing was applied, see Enable/
disable demosaicing on page 22.

Alignment: Indicates that the pixels of the image have
been corrected for the spatial distance
between its constituent pixels.

Non-uniformity: Indicates the image was corrected for non-
uniformity in the reference spectrum pipeline,
see The irradiance pipeline on page 24

Table 8: Information in Extended view

5.5 Adjust the Analyze tab rendering settings

Rendering settings in the Acquire tab and the Analyze tab are independent of each other.
These settings are only view settings and do not affect the processing.
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1. Select the Analyze tab.
2. In the Rendering panel, from the drop-down list select one of the following options:

• Tiles: all bands are shown in the image window.
• Single band and select a band with the slider: the selected band is shown in the

image window.
• Color: creates an articial color image, applying CIE curves to the spectral data.

In case the sensor doesn't cover the visible spectrum range, the CIE curves are
transposed to the sensor's range to create a broadband color reconstruction.

• False color: specic single bands of interest for your sample are assigned to a
red, green and blue color channel to display a high contrast rendering in the image
window. Select the Red Band, the Green Band and the Blue Band with the
sliders.

• NDVI: the Normalized Difference Vegetation Index for agriculture. Select the Red
Band and the Infrared Band with the sliders.

3. Adjust the Gain with the slider.
The brightness changes.

4. Adjust the Gamma with the slider.
The intensity of the middle tones changes without changing much the highlights and the
shadows.

5. Adjust the Contrast with the slider.
The contrast between lighter and darker midtones changes.

6. At Colormap: (only applicable if Tiles, Single band or NDVI are selected in step 2),
from the drop-down list, select an appropriate color map.

See also
Adjust the Acquire tab rendering settings on page 23

5.6 Image selection actions

In the HSI Mosaic image window, you can make selections in the image to visualize spectra.
You can use multiple layers and multiple selections in each selection layer.

Each layer has its own color and will be recognized as such in the image window and all related
panels in the HSI Mosaic user interface.
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See also
Selection actions workow example on page 40
Add a rst selection in a rst selection layer on page 42
Add a new selection layer on page 43
Add a selection to a selection layer on page 43
Clear the selections in a selection layer on page 43
Delete a selection layer on page 44
Delete all selection layers on page 44
Change the color of a selection layer on page 44
Change the name of a selection layer on page 44
Export the selection information and/or mask for reuse on page 45
Import the selection information and/or mask for reuse on page 45
Right click image selection shortcuts on page 42

5.6.1 Selection actions workow example

This example demonstrates how to distinguish nuts from their shells using a snapshot SWIR
camera. Specically this demo exploits differences in lipid absorption between both object
types, which heavily inuences the shape of the spectrum in the SWIR spectral range.

You rst acquire (or import) an image of the separate objects, adjust the rendering options
and then start your analysis.

1. You add a rst selection in the rst selection layer with the color blue and give the selection
layer the name 'nuts'

2. You add multiple selections of the nuts.
3. You add a second layer with the color green and give it the name 'shell exterior'.
4. You add multiple selections of the exterior of the shells
5. You add a third layer with the color fuchsia and give it the name 'shell interior'.
6. You add multiple selections of the interior of the shels

In the image below three layers with a selection for each layer are shown:

Figure 10: Selection layers with selections

The spectrograph and histograph are plotted in real-time as soon as you start adding
selections. For the nuts and shells blue, green and fuchsia graphs will be plotted.
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Figure 11: Spectrograph

Figure 12: Histograph

You can now use the selection layers to classify the image: this allows you to recognize other
parts of the scene as nuts or as shell interior or exterior.
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Figure 13: Class image

You can export the selection information to reuse it with other similar images. For example,
you want to analyze the image of nuts and shells. You import the selection information
and start adding selections in the image in the preloaded layers and can start analyzing and
classifying.

You can also export the selection mask for reuse. For example, you want a colleague to be
able to reproduce your analysis of the nuts and shells image using the same selections (mask).

5.6.2 Right click image selection shortcuts

Right click
shortcut

Description

Add a new selection layer with the last used selection tool (for example 
Rectangle).

Clear all selections in the current selection layer.

Table 9: Selection shortcuts

5.6.3 Add a rst selection in a rst selection layer

1. In the Analyze tab, in the Selection panel, select one of the following selection tools:

•  Freehand
•  Line
•  Rectangle
•  Circle

2. In the image window, click and hold to drag a selection.
A rst selection is created in the image in a rst selection layer. The layer is shown in the
Selection panel. The graphs in the Spectrograph and Histograph panels are plotted in
real-time.
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See also
Add a new selection layer on page 43
Add a selection to a selection layer on page 43
Right click image selection shortcuts on page 42

5.6.4 Add a new selection layer

In the Analyze tab, in the Selection panel, select .
A new selection layer is generated and added to the list in the Selection panel.The selection
layer is now active and new selections will be added to this layer until you select another layer.

See also
Add a rst selection in a rst selection layer on page 42
Add a selection to a selection layer on page 43
Delete a selection layer on page 44
Change the color of a selection layer on page 44
Change the name of a selection layer on page 44
Right click image selection shortcuts on page 42

5.6.5 Add a selection to a selection layer

1. In the Analyze tab, in the Selection panel, select a selection layer.

NOTE
When no layer is available, adding a selection, automatically creates the rst selection
layer, see Add a rst selection in a rst selection layer on page 42 or Add a new
selection layer on page 43.

2. Select one of the following selection tools:

•  Freehand
•  Line
•  Rectangle
•  Circle

3. In the image window, click and hold to drag a selection.
A new selection is added to the image in the selection layer color. The graphs in the
Spectrograph and Histograph panels are plotted in real-time in the color of the new
layer.

See also
Clear the selections in a selection layer on page 43

5.6.6 Clear the selections in a selection layer

Clearing the selections in a selection layer doesn’t delete the selection layer itself.

In the Analyze tab, in the Selection panel, at the selection layer, double click .
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See also
Delete a selection layer on page 44
Delete all selection layers on page 44
Right click image selection shortcuts on page 42

5.6.7 Delete a selection layer

When you delete a selection layer, the layer and its selections are deleted.

To only delete the selections in a selection layer, see Clear the selections in a selection layer on
page 43.

1. In the Analyze tab, in the Selection panel, select a selection layer.
2. Click .

The layer and all its selections are deleted.

See also
Clear the selections in a selection layer on page 43
Delete all selection layers on page 44

5.6.8 Delete all selection layers

In the Analyze tab, in the Selection panel, click .

See also
Clear the selections in a selection layer on page 43
Delete a selection layer on page 44

5.6.9 Change the color of a selection layer

1. In the Analyze tab, in the Selection panel, double click the color of the selection layer.
The Select Color dialog box appears.

2. Use one of the following options to select a color:

• Select one of the Basic colors or other color maps and adjust with the brightness
slider.

• Click Pick Screen Color and click on a color anywhere in one of your computer
displays.

• Enter your own color preferences in the text boxes.
3. Click OK.

See also
Change the name of a selection layer on page 44

5.6.10 Change the name of a selection layer

1. In the Analyze tab, in the Selection panel, double click the name of the selection layer.
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2. Use Backspace to delete and enter the new name.
3. Click anywhere next to the selection layer to conrm.

See also
Change the color of a selection layer on page 44

5.6.11 Export the selection information and/or mask for reuse

You can export selection information and/or masks to reuse them later for acquisition images.

• The exported selection layer information can be reused for analyzing other but similar
images. When you import the selection layer information, you can add selections in the
new images in these preloaded layers and start analyzing and/or classifying.

• The exported mask can be reused, for example, by another user to analyze the same
image.

1. In the Analyze tab, in the Selection panel, click .
The ExportDialog dialog box appears.

2. (Optional) At Folder:, click  to change the destination folder.
3. At Preferences select one or more of the following options:

• Information: selection layer information.
• Mask: the selection mask; all layers are attened in one image.

See also
Export/import: overview on page 12
Import the selection information and/or mask for reuse on page 45

5.6.12 Import the selection information and/or mask for reuse

You can export selection information and/or masks to reuse them later for acquisition images.

• The exported selection layer information can be reused for analyzing other but similar
images. When you import the selection layer information, you can add selections in the
new images in these preloaded layers and start analyzing and/or classifying.

• The exported mask can be reused, for example, by another user to analyze the same
image.

1. In the Analyze tab, in the Selection panel, click .
The Import selection model dialog box appears.

2. Browse for and select the desired les:

• SMDL: Information le format.
• PNG: Mask le format

3. Click Open.

See also
Export/import: overview on page 12
Export the selection information and/or mask for reuse on page 45
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5.7 Spectrograph analysis

When you make a selection in the image in the image window, the selection is immediately
visualized in the spectrograph in the corresponding color of the selection layer (unless all
visibility statuses in the spectrograph panel are set as hidden).

During analysis the spectrograph shows the reectance as a function of the wavelength.

Figure 14: Spectrograph

Following graphs are Visible ( ) or Hidden ( ):

• The Mean reectance of the selection(s) at each wavelength.
• The Minimum reectance of the selection(s) at each wavelength.
• The Maximum reectance of the selection(s) at each wavelength.
• The Interval between the minimum and maximum reectance
• The reectance at each spectrum at the Cursor (mouse pointer) position of the

image.

See also
Histograph analysis on page 47
Export spectrograph data on page 46

5.8 Export spectrograph data

In the spectrograph, the current graph can be exported as a PNG image or a CSV spreadsheet
le, see Spectrograph CSV le format on page 57. In the CSV export le, each row has
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values for all bands for a pixel. If a mean value export is made, each selection will have one
data entry. Otherwise each pixel in each selection will be saved as a single row.

1. Select the Analyze tab.
2. In the Spectrograph panel, select .

The ExportDialog dialog box appears.
3. At Destination, click  to select the destination Folder:.
4. At Name:, enter the name of the le(s) that will be saved.
5. At Preferences select one or more of the following options:

• Screenshot: a screenshot (PNG) of the current spectrograph in the
Spectrograph panel will be generated.

• Spectrums and from the drop-down list, select Mean or All: a CSV le will be
generated with respectively the average spectrum or all spectra of each selection.

NOTE
Exporting all spectra may generate very large CSV les.

6. Click OK.

See also
Spectrograph analysis on page 46
Export/import: overview on page 12

5.9 Histograph analysis

When you make a selection in the image in the image window, the selection is immediately
visualized in the histograph in the corresponding color of the selection layer.

Figure 15: Histograph

The histograph shows the pixel counts as a function of the reectance at a specic wavelength.
The wavelength is selected by sliding the slider in single band image rendering. The histograph
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of a selection which is mainly in the high reectance or 'light' areas of the image will result in
high peaks on the right side of the graph, 'dark' selections will result in high peaks on the left.
Average reectance area selections will result in peaks in the middle of the graph.

See also
Spectrograph analysis on page 46

5.10 Classication

HSI Mosaic allows you to group and mark pixels with the same spectral shape as the pixels
you select. In an image of a tree for example you can select some healthy leafs and HSI Mosaic
will recognize other pixels in the whole image as healthy leafs and mark them as such. You can
repeat this process in a second selection layer, for example, for dry leafs, etc.

HSI Mosaic uses spectral angle mapping (SAM) for classication. The spectral angle or
correlation between the pixels of the image and the pixels of the selection layer is calculated.
When pixels differ less than a set maximum angle, they are allotted to the same class. The
imec SAM classier is implemented in HSI Mosaic and ready to use. HSI Mosaic provides also
integration with the perClass Mira classier.

NOTE
The spectra of individual pixels can be described as vectors in an n-dimensional space,
where n is the number of spectral bands. Each vector has a certain length representing the
brightness of the pixel and a direction representing the spectral shape of the pixel. The more
similar the spectra are, the better they correlate, and the smaller the spectral angle between
them.

5.10.1 Classication workow

HSI Mosaic allows you to classify images, for example images of trees in a forest.

48



Figure 16: Classication panel and class image

Step Related topics

Create a selection layer with one or more
selections for each class. For example, create
a rst selection layer with different selections
of leaf-parts in the image of the tree. Then
create a second layer with selections of
branches of the tree.

Image selection actions on page 39

Set the classifying parameters: classier,
maximum angle and minimum intensity

Set up the classifying parameters on page
50

Classify on page 50

Select a classier on page 50

Classify Classify on page 50

Clean up pixels that do not contribute to a
particular class.

Clean up the class image on page 51

Reuse the classier: after classifying an
acquisition, you can export your classier,
acquire a new image (or import or live stream
one), import the classier and classify the
image.

To analyze the data in the spectrograph and
histograph, you need to convert the classes to
selections.

Export the classier on page 51

Import a classier on page 52

Convert to selection on page 52

Export Export the class image on page 52
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Table 10: Classify workow steps

5.10.2 Set up the classifying parameters

To classify an image, you can set two parameters:

• The Maximum angle (degrees): the maximum angle that HSI Mosaic uses to
classify pixels of the image in the same (spectral angle) class as the selection layer.

• The Minimum intensity: used to lter out noise. Noise on low intensity spectra has
a big impact on the spectral angle. Pixels with an intensity lower than this minimum
intensity are not classied.

1. In the Analyze tab, in the Classication panel, at Maximum angle (degrees):, enter
the maximum spectral angle difference.

2. At Minimum intensity:, enter the minimum spectrum intensity.

See also
Classication workow on page 48

5.10.3 Select a classier

HSI Mosaic uses spectral angle mapping (SAM) for classication, see Classication on
page 48 and Classication workow on page 48. The default imec SAM classier is
implemented in HSI Mosaic and ready to use. HSI Mosaic provides also integration with the
perClass Mira classier.

In the Analyze tab, in the Classication panel, at Classify:, from the drop-down list, select
a SAM classier.

See also
Classication workow on page 48
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5.10.4 Classify

Figure 17: Classication panel and class image

In the Analyze tab, in the Classication panel, enable Classify:. The pixels of the image
are classied based on your selections and according to the classifying parameters. This results
in the class image in the image window, where the class image is overlayed on the rendering,
and in the Class image panel.

NOTE
Layers can be shown/hidden individually ( ) or at once ( ), see Show/hide an item or
selection on page 12.

See also
Classication workow on page 48

5.10.5 Clean up the class image

After classication, there are usually still loose pixels or small pixel aggregations that often do
not contribute to a particular class. These artifacts can be eliminated with the clean-up tool.

1. In the Analyze tab, in the Classication panel, enable Clean up:.
2. At Minimum agregate size: enter the size of the pixel aggregates that have to be

cleaned up.

See also
Classication workow on page 48

5.10.6 Export the classier

After classifying an acquisition, you can export your classier. You can reuse this classier later:
acquire a new image (or import or live stream one), import the classier and classify the image.
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1. In the Analyze tab, in the Classication panel, click .
The ExportDialog dialog box appears.

2. At Destination, click  to select the destination Folder:.
3. At Name:, enter the name of the XML le that will be saved.
4. Click OK.

See also
Export/import: overview on page 12
Import a classier on page 52
Export the class image on page 52

5.10.7 Import a classier

After classifying an acquisition, you can export your classier. You can import this classier to
reuse it for classifying a new image acquisition (or an imported offline one or a live stream).

1. In the Analyze tab, in the Classication panel, click .
The Import classier window opens.

2. Browse for the classier XML le and click Open.
The classier is imported and can be used to classify.

See also
Export/import: overview on page 12
Export the classier on page 51
Convert to selection on page 52

5.10.8 Convert to selection

The convert to selection functionality is only available in extended view.

When you imported a classier to reuse it in another acquisition, you can convert this
classier's classes to selection layers, providing you a spectrograph and histograph for analysis.

In the Analyze tab, in the Classication panel, at Classes: click  Convert to
selection.
The classes are converted to selections and the spectrograph and histograph are shown for
these selection layers.

5.10.9 Export the class image

Classication info of an acquisition can be exported to a XML le, see Classier XML le
format on page 57. This le can be imported to another classication.

1. Select the Analyze tab.
2. In the Class image panel, select .

The ExportDialog dialog box appears.
3. At Destination, click  to select the destination Folder:.
4. At Name:, enter the name of the XML le that will be saved.
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5. Click OK.

See also
Classication workow on page 48
Export/import: overview on page 12
Export the classier on page 51

5.11 Export metadata

1. Select the Analyze tab.
2. In the Metadata panel, select .

The ExportDialog dialog box appears.
3. At Destination, click  to select the destination Folder:.
4. At Name:, enter the name of the CSV le that will be saved.
5. Click OK.

See also
Export/import: overview on page 12
Export collections and/or context on page 33

5.12 Output le formats

5.12.1 ENVI le format

All processed acquisitions (hypercubes) can be exported to binary les. An ENVI standard
compatible header le is also exported together with the data. ENVI is a commonly used
format in the HSI area. ENVI header le includes important parameters that lets different
viewer software to read the binary information correctly. The HSI Mosaic export le header
includes ENVI standard information plus imec specic info which will only be used by imec
software. Other ENVI reader software can read les exported from HSI Mosaic without any
problems.

NOTE
The header and/or binary les of some ENVI reader programs and scripts must have a
specied le extension. It causes no problems if you change the le extension.

ENVI Standard

Variable Description

acquisition time Time of the image acquisition in YYYY-MM-
DDTHH:MM:SS:Dooo:mm format. Dooo is the time offset from
UTC time.

band names The names of image bands.

bands The number of bands per image le.
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Variable Description

byte order Order of the bytes in the data. 0 - Least Signicant Byte First 1 -
Most Signicant Byte First

data type The type of data representation:

1 = Byte: 8-bit unsigned integer

2 = Integer: 16-bit signed integer

3 = Long: 32-bit signed integer

4 = Floating-point: 32-bit single-precision

5 = Double-precision: 64-bit double-precision oating-point

6 = Complex: Real-imaginary pair of single-precision oating-
point

9 = Double-precision complex: Real-imaginary pair of double
precision oating-point

12 = Unsigned integer: 16-bit

13 = Unsigned long integer: 32-bit

14 = 64-bit long integer (signed)

15 = 64-bit unsigned long integer (unsigned)

le type The ENVI-dened le type. Please check ENVI standard
documentation for more details.

fwhm Lists full-width-half-maximum (FWHM) values of each band in an
image.

header offset The number of bytes of embedded header information present in
the le. ENVI skips these bytes when reading the le.

interleave Refers to whether the data interleave is Band Sequential (BSQ),
Band-interleaved-by-pixel (BIP) or Band-interleaved-by-line (BIL).

lines The number of lines per image for each band.

samples The number of samples (pixels) per image line for each band.

wavelength Lists the center wavelength values of each band in an image.

wavelength units Text string indicating the wavelength units.

Table 11: ENVI Standard

imec extension

Variable Description

max value Maximum pixel value possible in the data.
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Variable Description

saturation value Starting from this value to the max value,
pixels will be shown as oversaturated.

no data value Value used to ag invalid data.

data source Name and version of the acquisition software.

system id Identication number of the sensor.

correction matrix name Name of the correction matrix used in the
image.

exit_pupil_distance_mm Exit pupil distance of the lens to the sensor.

f_number If the aperture opening is f/2.8, f number will
be 2.8.

sensor_refractive_index Refractive index of the sensor. Please refer to
HSI Sensors User Manual.

spatial median lter size Size of the median neighborhood

white value Coefficent used in the white balancing if white
balancing is applied.

Table 12: imec extension

Flags

Flags directly refer to the related operation in the processing pipeline.

Flag Value

corrected data 0 (Off) or 1 (On).

reectance data 0 (Off) or 1 (On).

alignment 0 (Off) or 1 (On).

angularity correction 0 (Off) or 1 (On).

bias correction 0 (Off) or 1 (On).

non-uniformity 0 (Off) or 1 (On).

spatial median ltering 0 (Off) or 1 (On).

spatial resampling 0 (Off) or 1 (On).

spectral correction Deprecated, do not use.

white balancing Deprecated, do not use.

Table 13: Flags

See also
Export collections and/or context on page 33
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5.12.2 Export data XML le format

Unprocessed acquisitions (cubes) can be exported to binary les. An XML header le is also
exported together with the data. The header le includes important parameters that lets HSI
Mosaic to read the le in the analyze section later.

Data format

Variable Description

byte_depth Number of bytes used in the data type.

data_type Type of the exported data. (Float, int, etc...)

max_value Max possible value of the data.

saturation_value Starting from this value to the max value,
pixels will be shown as oversaturated.

no_data_value Value used to ag invalid data.

nr_cols Number of columns in image in pixels.

nr_rows Number of rows in image in pixels.

offset_sensor_x The image starts from this pixel on the sensor
in the X axis.

offset_sensor_y The image starts from this pixel on the sensor
in the Y axis.

Table 14: Data format

Data info

Variable Description

data_source Name and version of the software which
exported the data.

system id ID tag of the camera system.

valid Flags whether the data is valid or not.

acquisition_time Time of the image acquisition in YYYY-MM-
DDTHH:MM:SS:Dooo:mm format. Dooo is
the time offset from UTC time.

completion_time Time of the completion of acquisition.

integration_time_ms Integration time in ms.
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Table 15: Data info

Properties

Variable Description

burst_index Imec Internal

dm lost frames Imec Internal

gain mode Imec Internal

hdr ag enabled Imec Internal

hdr integration times per band Imec Internal

hdr nr frames Imec Internal

number of averaged frames Imec Internal

sensor bit depth Number of bits per pixel.

timestamp s Imec Internal

Table 16: Properties

See also
Export collections and/or context on page 33

5.12.3 Spectrograph CSV le format

In the spectrograph, the current graph can be exported as a PNG image or as a CSV
spreadsheet le. In the CSV export le, each row contains values for all bands for a pixel. If a
mean value export is made, each selection will have one data entry. Otherwise each pixel in
each selection will be saved as a single row.

Variable Description

Name Name of the selection.

Color Color of the selection.

x X position of a pixel in the selection area.

y Y position of a pixel in the selection area.

Table 17: Histograph

See also
Export spectrograph data on page 46

5.12.4 Classier XML le format

Classication info of an acquisition can be exported to a XML le. This le can be imported to
another classication.
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Classier XML

Variable Description

input_dimensionality Number of bands.

nr_classes Number of classes.

max_angle_degrees Maximum angle value used for the exported
classication.

min_intensity Minimum intensity value used for the
exported classication.

Table 18: Classier XML

Class infos

This part is the identication of the selections used for classications.

Variable Description

version Version of the class info.

id ID number of the class.

name Name of the class

color Color coding of the selection in #RRGGBB.

Table 19: Class infos

Centroids

Classication info of an acquisition can be exported to a XML le. This le can be imported to
another classication.

Variable Description

version Version of the centroid info.

class_id ID number of the class.

nr_elements Number of band values stored for dening
this centroid. After this variable, all values are
stored back to back with a space character
between them.

Table 20: Centroids

See also
Import a classier on page 52
Export the classier on page 51
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